96 CBR 600 f3 few mods

RideCBR.com Forums General Tech Discussions 96 CBR 600 f3 few mods

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of hubbard2a hubbard2a 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #79128
    Profile photo of michaelmartin
    michaelmartin
    Registered Member
    Training Wheels
    Points: 140

    I’ve barely ridden my 96 600 since I bought it it was slipping to begin with, now it has no power at all it cranks right up but will not pull at all I’ve checked fluid etc what else could it be besides my clutch slipping and stuck? Any advice appreciated thank you

    #79131
    Profile photo of hubbard2a
    hubbard2a
    Registered Member
    RideCBR Guru
    Points: 13,128

    Think you may have answered your own question….. If the clutch was already slipping, I doubt it would take much to finish it off. It would at least be my starting point. If you dont already have a shop you use. Ask around, see who has the best reputation by word of mouth, And it would be some one I can talk to and relate to. My personal shop it also my local hang out and I consider all of the guys who work there and the regular customers to be good friends. I trust them, and they wont ster me wrong. Plus I usually get little perks and discounts. But I only buy from him, even t shirts and gear. works well for both of us.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.