CBR 600 F3 Instrument Panel Bulbs

RideCBR.com Forums General Tech Discussions CBR 600 F3 Instrument Panel Bulbs

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of saturnv saturnv 1 year ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #77144
    Profile photo of saturnv
    saturnv
    Registered Member
    RideCBR Guru
    Points: 22,730

    Does anyone know what size the bulbs are? I’ve just got some 12V, 1.7W bulbs but they look too big – too lazy to take the fairing off again to check but will do soon I suppose…

    The ones I got are called: capless bulbs, Large and dimensions are: 25 x 10 mm with flat terminals (not screw thread)

    Thanks

    #77209
    Profile photo of drewz97cbr600f3
    drewz97cbr600f3
    Registered Member
    RideCBR Newbie
    Points: 455

    Hey saturnv I’m in need of changing my speedometer bulb but am sidetracked at the moment with troubleshooting of a slight loss in overall horsepower which led to the reconnecting a mysteriously disconnected PAIR control valve air intake hose which then snowballed into a split fuel tube that I noticed just after I bolted my tank back on and gave the fuel shut off valve a 1/8th turn to check for leaks. For the lights, you are working out of the Honda Shop Manual same as me, right?

    #77212
    Profile photo of saturnv
    saturnv
    Registered Member
    RideCBR Guru
    Points: 22,730

    Hey Drew,

    Yes thanks I ordered some bulbs that looked correct in the picture (capless 12V, 1.7W) but when they arrived they were too big for the socket. My local motor spares shop also stocks the right spec (electrically speaking) but they are tiny & too small! Have ordered more online & hoping they’ll be the medium sized ones & just the right size… If not I’ll get the tiny ones and adapt the socket to make it smaller internal diameter. All my warning lights are working fine it’s just one bulb needed for extra illumination of the gauges. Apart from 1 blown bulb there was a fault with the flexi-circuit tracks as I call them – water had got in over the years and corroded the tracks away so the blue HI headlight warning socket was getting no 12V feed. Repaired that by soldering a wire across…

    Cheers,

    Tim

    #77213
    Profile photo of saturnv
    saturnv
    Registered Member
    RideCBR Guru
    Points: 22,730

    Hi Drew,

    Forgot to say, hope you sort out your other issues ok – we don’t have PAIR on the UK model but I do have that on my CBF1000 as part of the fuel injection system I believe. I checked all my induction hoses and valves when I did my carb cleaning and synchronisation and all seemed good. Also replaced the fuel pump points and the fuel filter so she’s running good – shame I hardly ever ride my CBR due to back ache these days :-(

    Tim

    #77215
    Profile photo of saturnv
    saturnv
    Registered Member
    RideCBR Guru
    Points: 22,730

    Good news – the bulbs arrived today and they were the correct size and spec so I was able to complete the job… All good!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.